Hello,


First of all, thank you to everyone that contributes here.  I'm new to the ning community and this place has been a godsend when it comes to CSS.

Onto my issue... and I apologize if its tabboo to post the same message here as in ning creators... if that's the case, it won't happen again - I'm just at a loss on this issue:

 

I need to post 3 images in one module on my front page for an effect in the graphic design.  No matter what I do or how I try... I cannot get rid of the spacing between the images with this new text editor... Any ideas on this?

Views: 118

Reply to This

Replies to This Discussion

Nah, no problem posting in both places. A lot of people do this. Unfortunately I can't take a look since your site is invitation only. Here's a tip that may help - when I add a table to a text box, and I want to remove spacing, I have to add special styles to override the built-in styles. I can't say that it will remove all spacing, because I don't think I've ever needed that. Here's an example of the code I use when I add twitter and facebook icons side-by-side, when Ning throws in too much padding. Notice I apply 0 to images and margins:

Join Our Facebook Fan Page Follow Us On Twitter

<style>.xg_module_body img {margin:0!important;} table {margin:0px!important;}</style>

<div align="center"><table cellpadding="0" width="156" cellspacing="0"><tr>
<td><a href="http://www.facebook.com/yourpage" target="_blank"><img src="http://api.ning.com:80/files/f1jUQQMVBKMkoK7J6tb5rjRMpP98d-a5jsJb3mbBZeLXLT175RDyyx1lZ2NWW8xpl9JTsuYU3NkKF8xz-W1EKJ6ktt8OYkN0/facebook.png" alt="Join Our Facebook Fan Page" width="64" height="64" border="0"></a></td>
<td><a href="http://twitter.com/yourtwitter" target="_blank"><img src="http://api.ning.com:80/files/g1ILkYASHAQ-Cz3fv0-1TRB8XgDWLXl4T61S3Byc4QWOnGJ-ZZI*yWrLqkKTlpPfcWI7seA7A31gt2s7RoHrNtvCvARxcC2I/twitter.png" alt="Follow Us On Twitter" width="64" height="64" border="0"></a></td></tr></table></div>

 

Also, you could consider making one large image and inserting image maps if you need a link for each image. I have found that image maps work pretty well on Ning.

 

Good Luck - - and happy to hear JenSocial has helped you out,

Jen

 

Hi!

Thanks so much for your fast reply!  The answer to my question was answered to perfection in your first line:

 

<style>.xg_module_body img {margin:0!important;} table {margin:0px!important;}</style>

 

This is the code I needed to over-ride the text editors spacing...

 

Thanks again!
Drew

That's great to hear, glad it helped!

Happy Holidays,

Jen

Hi there, I've hit one more roadblock with the new text editor that might be the death of my current ning and the one I had planned... both media based. I have hundreds of the following embeds that took me weeks to build. They are more custom that the example I'll give here but you'll get the idea.

Nothing I try works... html input... media embed feature... WYSIWYG entries... it shows the frame of the player but none of the specs and the video won't play. If you could plug this in and see if I need to add/edit/subtract anything I'd greatly appreciate it. It's important that I use this specific player as my embeds are already set up with it along with custom bumper graphics, skins etc...

The code is uploaded as a .rtf.

 

*** Also, our site is closed off until we're finished with the graphic design... if you need access for easier replies I'd be happy to email you an invite or get you a login email/password.***

 

Thanks!

Drew

thelaststop.ning.com

 

PS: I'm not ignorant of the time this takes you. I'll be showing my thanks on my next paycheck, 12.24.

Attachments:

Where are you adding the code? Text Box, Discussion Text Box, new Page, etc...

Two things: Good news is, Ning is about to add Settings for the Editor. And, I added your particular situation and what happened to me when I tested your code here:

http://creators.ning.com/xn/detail/4244211:Comment:394632

If you read the top of this discussion, you'll see the plans for the Editor Settings.

Best,

Jen

Hi Jen,

 

Running late for work... To answer your first question... All of my issues are on the front page modules. 

 

I'll read further into your link and second post when I get to work tonight.


Thanks!
Drew

Hi Jen,

 

It seems that even after the new changes went into effect, the videos won't play.  This is bad news as my next ning side was 100% dependent upon these embeds working as they did before the change-over. 

 

Notes:

These are for text boxes on the main page.
I've disabled the default WYSIWYG
Still the same result... the embedded player shows but the custom aspects do not and the video will not play.

I'm having the same problem, since you brought it up. We're both going to need to submit a support ticket to Ning.

Good luck, and I feel like it will get sorted out soon. Do be sure to submit the ticket.

Best,

Jen

http://screencast.com/t/11zVQIcxfEki

 

Sent... I'll update you if I get a response...


Thanks!

Drew

Hi Drew,

Wow, it took all day on/off to find this discussion, so I could share what Ning sent me about your issue. This is a good reminder for both of us, to start new support discussions when it's about something else.

 

Anywho, somehow I got the top Ning Engineer (Manager actually) involved in this, almost feel guilty I've taken up so much of his time. He has sent several fixes to the original code you provided. And, the reason I feel badly, I should have caught the problem early on. Not to say that the Text Editor didn't change your code. This, I'm not sure about, and you will need to compare the code that works, what he provided - - to your original code.

 

<object type="application/x-shockwave-flash" data="http://flv-player.net/medias/player_flv_multi.swf" width="320" height="240">
<param name="movie" value="http://flv-player.net/medias/player_flv_multi.swf" ></param>
<param name="allowFullScreen" value="true" ></param>
<param name="FlashVars" value="flv=http://www.archive.org/download/11.28-Round6/Driven_512kb.mp4" ></param>
</object>

 

I also uploaded text file, in case the code above is broken in the comment box.

 

If you compare this code to your original, this is the problem area (from original):

 

flv=http%3A


Good Luck,

Jen

Attachments:
Same here. Thanx Jen.

RSS

Members

© 2023   Created by JenSocial.   Powered by

Badges  |  Report an Issue  |  Terms of Service

Home
VIP Ning Tips